Wave editor does not show ruler

General discussion about Music Studio.

Wave editor does not show ruler

Postby Kolbaska » Wed May 11, 2016 3:32 pm

The first thing I noticed when was exploring the new ruler units swap feature is that the waveform no longer split into smaller parts. It only shows values in seconds of both left and right marker. Where did this grid gone?
Kolbaska
 
Posts: 35
Joined: Wed Apr 22, 2015 6:13 pm

Re: Wave editor does not show ruler

Postby Alex » Fri May 13, 2016 8:00 pm

You discovered a major bug, thanks! I don't know you this bug slipped through testing, since the ruler's units were a new feature and the last time I tested it it still worked :oops:

I added it to the list of known issues, we'll release version 2.6.5 asap:
viewtopic.php?f=8&t=3857&p=8959#p8959
Image Image
Alex
 
Posts: 2119
Joined: Wed Jun 23, 2010 4:55 pm
Location: Austria

Re: Wave editor does not show ruler

Postby Kolbaska » Tue May 17, 2016 9:54 pm

Hey Alex!

Glad to hear this will be resolved soon.

Meanwhile another probably a bug. I noticed that "Undo" and "Redo" buttons also change rulers positions. I don't remember this feature to be in older versions but anyway just letting you know.

P.S. In case this done on a purpose, I can't say this is comfortable :P
Kolbaska
 
Posts: 35
Joined: Wed Apr 22, 2015 6:13 pm

Re: Wave editor does not show ruler

Postby Alex » Wed May 18, 2016 9:11 am

Kolbaska wrote:Meanwhile another probably a bug. I noticed that "Undo" and "Redo" buttons also change rulers positions. I don't remember this feature to be in older versions but anyway just letting you know.
P.S. In case this done on a purpose, I can't say this is comfortable :P

It's too late now for a fix, version 2.6.5 will be released today. Btw it's been like this since version 2.0. It's not a bug, but you're right, it's not very practical that the wave editor's zoom is reset on undo.
Image Image
Alex
 
Posts: 2119
Joined: Wed Jun 23, 2010 4:55 pm
Location: Austria

Re: Wave editor does not show ruler

Postby Kolbaska » Wed May 18, 2016 4:09 pm

Alex wrote:...it's not very practical that the wave editor's zoom is reset on undo.


Well, the topic is about Wave editor, however the thing I was talking about are rules (oh, I just looked into the User Guide; the correct name is Markers). So the odd behavior described by me earlier applied for markers for both track screen and track editor sections.
Kolbaska
 
Posts: 35
Joined: Wed Apr 22, 2015 6:13 pm

Re: Wave editor does not show ruler

Postby Alex » Thu May 19, 2016 1:11 pm

I can't reproduce the issue, here's what I tried:
* Move the right marker to the middle of the song
* Add a MIDI track
* Undo
-> The right marker didn't move, it's still in the middle of the song, as expected.
What do you do differently?
Image Image
Alex
 
Posts: 2119
Joined: Wed Jun 23, 2010 4:55 pm
Location: Austria

Re: Wave editor does not show ruler

Postby Kolbaska » Thu May 19, 2016 3:37 pm

Alex wrote:What do you do differently?

The order. Taking your case, swap 1st and 2nd steps. So,
* Create a new project
* Add a MIDI track
*Move any marker to any position
* Undo
Kolbaska
 
Posts: 35
Joined: Wed Apr 22, 2015 6:13 pm

Re: Wave editor does not show ruler

Postby Alex » Tue May 24, 2016 11:13 am

Right, thanks! We'll probably fix this bug in version 3.
Image Image
Alex
 
Posts: 2119
Joined: Wed Jun 23, 2010 4:55 pm
Location: Austria

Re: Wave editor does not show ruler

Postby Bianca » Tue May 24, 2016 4:30 pm

Actually I would kind of expect the markers to go back to where they were before you moved them if you press undo.
Bianca
 
Posts: 439
Joined: Tue Jan 11, 2011 9:07 pm

Re: Wave editor does not show ruler

Postby Kolbaska » Tue Jun 21, 2016 4:47 pm

Bianca wrote:Actually I would kind of expect the markers to go back to where they were before you moved them if you press undo.

That would be fine if markers' movement was recorded as a separate action, but atm it's not.
Kolbaska
 
Posts: 35
Joined: Wed Apr 22, 2015 6:13 pm


Return to General discussion

Who is online

Users browsing this forum: No registered users and 2 guests